User manual and tutorial

This manual will show you how to use Blurity to remove the blur from a blurry image.

If you need additional help, please feel free to get in touch with us at We guarantee that a real person will answer you within 24 hours, probably faster. Happy deblurring!

1. Example videos

Want to see a few examples of how you can use Blurity to fix your blurry photos? In the videos below, we walk you through the actual deblurring process. If you download the linked photos and follow along with the videos, you will be able to reproduce the results exactly as shown, on your own computer.

Simple blur repair example

Here's an example video showing the use of basic mode to fix a blurry picture of a hockey goalie.

Topics addressed in the video:

  • Use of "basic" mode
  • Sample box location selection

Useful links:

Advanced blur removal example

Looking for a bit more in-depth example deblurring, including what to do when the initial deblurring doesn't work well? Here's an example video showing the use of advanced mode to fix a blurry photo of a graphing calculator.

Topics discussed in the video:

  • Sample box location selection
  • What to do when the first "processing" try doesn't work well
  • Adjustment of the advanced parameters
  • Use of "advanced" mode

Useful links:

2. Overview

What Blurity is

  • Blurity is a tool to remove blur from pictures
  • Blurity is good at removing motion blur and minor focus blur
  • Blurity is best at removing camera shake from images
  • Blurity works best on images where the blur is consistent throughout the image
  • Blurity is for use on images that are properly exposed
  • Blurity works best on images that have low levels of noise
  • Blurity works on both digital photos and scanned film photos

What Blurity is not

  • Blurity is not a tool for making small images large
  • Bluirty will not improve small images that have been resized larger using another tool
  • Blurity is not for images where some parts of the images are blurred differently than other parts
  • Blurity is not for when some parts of an image are already sharp
  • Blurity is not for severely focus-blurred images
  • Blurity is not for removing JPEG compression artifacts from images

Compatible images

Blurity is designed to fix blurs in most everyday images, so long as they conform to these limits:

  • No more than 6000 x 4000 pixels in size (your limit may be lower if you have less than 4 GB of RAM)
  • At least 200 pixels on the shortest edge
  • JPEG or PNG format

If your image falls outside of the above limits, please edit it using a tool like Photoshop or Paint.NET prior to opening it in Blurity.

If you have at least 4 GB of RAM and are using the Mac OS X version of Blurity, you might be able to open images that are larger than the above limits.

Processing speed depends on a variety of factors, mostly image size, and may take a minute or more on computers built before 2010 or that have non-Intel processors.

Blurs that can and cannot be removed

Short version:

Mostly for fixing motion blur, but focus blur can also be fixed if it isn't too severe.

Blurity is primarily intended to remove blurs from motion-blurred images. Motion blur is blur caused by motion of the camera, the subject, or both.

Example of motion blur from nightstreets.jpg. Note the visible diagonal streaks, showing the motion of the camera while the shutter was open. Blurity can easily remove this blur.

Blurity is capable of removing significant amounts of motion blur from photos. The results are best when the motion blur is the same all around the image, such as when the blur was caused by camera shake.

Results are somewhat worse when different parts of the image have more motion blur than other parts, or when the motion blur in one part of the image is not consistent with the motion blur in another part of the image.

Blurity can also remove small amounts of focus blur. Focus blur is caused when the camera fails to focus on the image subject.

Example of focus blur that can be removed. The blur is relatively small, so Blurity will be able to significantly improve this image.

However, if the focus blur is extreme, there is not enough information left in the image to allow Blurity to deblur it.

Example of focus blur that cannot be removed. The image is so out of focus that it cannot be recovered.

When Blurity will not work

There are a number of other photo issues that cannot be improved by Blurity. For example, a photo exhibiting one or more of these conditions cannot be deblurred:

  • Overexposure
  • Underexposure
  • Photo taken at night with bright lights against a dark background
  • JPEG compression artifacts
  • Only small portion blurred, like somebody's face or an athlete's moving arm
  • Some parts of the image are blurred differently than other parts
  • Part of the image is already sharp
  • Lots of sensor noise (or grain) is visible
  • Images without much structure or definite edges, such as photos of fuzzy objects
  • Severe focus blur (more than a few pixels)
  • Rescaled images, such as small images made large
  • Image lit from both ambient light and an electronic flash simultaneously

To recap, Blurity is best for removal of motion blur from photos, such as from camera shake. Think of it as a sort of after-the-fact image stabilization tool. It can also remove other types of blur, so long as the blur is consistent throughout the image.

Practice blurry images

The file nightstreets.jpg is a good demo file for learning to use Blurity. It is a real image that exhibits about 18 pixels of linear motion blur in a diagonal direction. Notice how the blur is the same everywhere in the image.

The blurry calculator is another good example image for practicing blur removal. Again, notice how the blur is the same throughout the image.

The Blurity interface

Short version:

Use the magnifying glass button to zoom in and out.

You do not need to close the current image before opening a new image.

The Blurity interface is separated into three main sections: the deblurring parameters, the original image, and the deblurred image.

You can interact with Blurity using gestures and conventions that might already be familiar to you.

For example, to open an image, you can click the "Open image..." button, select "Open..." from the File menu, or drag an image file onto Blurity.

You can open a different image whenever you desire. You do not need to close any currently open image before opening the differnet image; the old image will be closed automatically.

If you want to zoom in or out on an image, you can click either of the magnifying glass buttons, double-click on the right image, or scroll up or down while hovering your mouse cursor over either image.

Blurity scales the displayed image to fit on your screen when you first open it. If you try to drag the image, you will see that Blurity automatically zooms in on the location that you started the dragging action. If you drag the image around while already zoomed in, you will stay zoomed in.

After you have processed your image, you can save the deblurred result by clicking either the "Save image as..." button or choosing "Save as..." from the File menu.


3. The tour


Blurity includes a built-in tour, which walks you through the deblurring process from start to finish.

If you have not used Blurity before, or if you are having trouble, we strongly recommend going through the tour. It shouldn't take more than five minutes to complete.

You can start the tour by selecting "Tour" from the Help menu.

4. How to deblur an image

Short version:

  1. Open the blurry image
  2. Click in the left image where the blur removal is most important
  3. Click "Process"

If the blur removal was poor, fiddle with the parameters or select a different spot for the red sample box, then process again.

There are four main steps to deblurring an image:

  • Open the blurry image using the "Load image..." button
  • Click a good location for the red sample box on the original (blurry) image
  • Adjust deblurring parameters if desired
  • Click the "Process" button

If the blur was removed successfully, save the image using the "Save image..." button. If the blur was not removed successfully, adjust either the sample box location (by clicking in a new spot on the original image) or the deblurring parameters, then click the "Process" button again.

You can zoom in and out using your mouse's scroll wheel, and if you click and drag on the images, you can pan around them. This can be useful in determining whether the blur was successfully removed.

Selecting a location for the sample box

Short version:

Blur not fixed? Try moving the sample box.

Small sample box location changes have have huge impacts on results.

Avoid uniform areas, dark areas, and light areas.

The part of the image in the sample box is what Blurity will use to build its model of the blur for the entire image.

Try to use the box to surround a part of the image that looks like a small circle or square.

The location of the sample box has a dramatic effect on the quality of Blurity's blur removal. The part of the image contained within the sample box is what Blurity uses to build its model of the blur for the entire image. If you are familiar with image processing or signal processing, you might also think of the sample box as a "window" or as a "region of interest."

The sample box locaiton is set by clicking at the desired location on the original image (the one on the left). Once the box has been placed, it can be moved by clicking and dragging.

The sample box should contain good examples of the blur present in the larger image. The best examples are usually medium-sized uniform shapes, like simple polygons.

The sample box should not contain areas of the image that are already sharp, are overexposed, or that are severely underexposed. The best locations are slightly underexposed. Including blown-out or solid-black areas in the sample box will lead to poor results.

It's also important to avoid including areas that are naturally fuzzy inside the sample box. Naturally fuzzy items include animal fur and human hair.

Don't be affraid to try several spots for the sample box.

Consider an example of a blurry calculator screen.

This is a bad location:

Bad sample box location. The blurred text is not a good example of the blur in the image, since there is no clear separation between it and the background.

It is just the blurry text, which is a poor example of the blur in the image. This won't work. We need a better location for the sample box.

This is a good location:

Good sample box location. The box contains good examples of the blur in the image. Notice how the yellow button is a simple shape, that the yellow button is a good example of the blur, and that the yellow button is completely enclosed by the sample box.

It contains both good structure (the yellow button) and fine detail (the writing on the other buttons). None of the area in the box is overexposed, and the blur within the box is consistent with the blur that we want to remove from the overall photo.

The location of the sample box can have an enormous impact on the quality of the blur removal. Changing it by just a few pixels can be the difference between an excellent deblurring and a total failure.

If you are having problems with blur removal, the first thing you should adjust is the position of the sample box.

The deblurring parameters

Short version:

When in doubt, use Basic mode.

If the blur removal is poor, first try changing the location of the sample box rather than changing the blur removal parameters.

The blur removal parameters can have a significant impact on the blur removal results and the amount of time needed to do the processing.

Basic mode versus Advanced mode

There are two ways to select the deblurring parameters in Blurity: Basic mode and Advanced mode.

In Basic mode, you specify the level of blur as somewhere between "normal" and "extreme." Based on your blur-level selection, Blurity will automatically choose the parameters used during the blur removal process.

The only thing you need to choose on your own is the location of the red sample box, which you can do by clicking on the original (left-side) image. As described elsewhere, you should choose a location that has both good structure and good detail.

In general, you should start with Basic mode on the normal level. Increase the blur level setting one notch at a time towards the extreme level, but only if you are unable to get satisfactory results at the normal level.

In Advanced mode, you have the full power and flexibility of Blurity at your fingers. The remainder of this section of the manual describes the Advanced mode parameters and how to choose them.

In general, the correlation between the Basic mode blur level and the Advanced mode individual parameters is as follows, though it can vary slightly depending on the situation:

Parameter Blur level
Normal Medium Extreme
Blur size 24 35 49
Sample box size 300 350 450
Solver filtering 10 10 10
Solver iterations 10 10 5
Blur model cleanup 30 30 30
Deconvolution noise reduction 40 40 40

Blur size

The blur size parameter affects the maximum size of the blur that Blurity will remove. The number represents the size in pixels.

Adjust when: the blur is significantly larger or smaller than the default.

Increasing will: allow Blurity to model larger blurs but increase the amount of time required for processing. It will also make the blur model more susceptible to noise, which could decrease overall image quality.

Decreasing will: reduce the amount of time required for processing and limit the amount of extraneous noise in the blur model, possibly increasing image quality. However, if the blur size is too small, the blur model might not be large enough to contain the entire blur.

Sample box size

The sample box size parameter adjusts the size of the red sample box, which affects how much of the image is used to develop a model of the blur. The number represents the size in pixels

Adjust when: the blur size is increased.

Increasing will: use more of the image for developing the blur model but lead to longer processing times. In addition, having a sample box that is too big could cause the blur model generation to fail entirely.

Decreasing will: use less of the image for developing the blur model and lead to shorter processing times. However, if the sample box size is too small, there might be insufficient information to build the blur model, causing it to fail entirely.

Solver filtering

The solver filtering level affects how much noise appears in the blur model. The number represents the reciprocal of the inter-iteration threshold.

Adjust when: the blur modeling fails or the blur model is very noisy.

Increasing will: reduce the amount of noise in the blur model, but might prevent fine structure in the blur model from developing.

Decreasing will: increase the amount of noise in the blur model, but might lead to innaccuracies in the blur model.

In general, adjustment of the solver filtering should rarely be necessary.

Solver iterations

The number of solver iterations affects how long the solver will work on refining the model of the blur.

Adjust when: the model of the blur is poor or noisy.

Increasing will: increase the time spent by the sovler on the blur model, possibly improving the accuracy of the model. However, if the number of iterations is too high, the solver will over-solve the blur and produce an inaccurate model.

Decreasing will: reduce the time spent by the solver on the blur model, possibly improving the high-level structure of the blur model at the expense of its absolute accuracy. Yes, using fewer iterations can often improve the quality of the blur model.

As a rule of thumb, if you're having problems with deblurring and you've already tried at least half a dozen sample box locations, try decreasing the number of solver iterations.

Blur model cleanup

Adjusting the blur model cleanup can reduce the amount of "shot" noise in the blur model. Reducing the amount of shot noise can reduce the number of visual artifacts in the processed image and increase the amount of detail recovered.

Shot noise, at least as used in Blurity, refers to single bright pixels in the blur model surrounded by black pixels.

This parameter adjusts the threshold at which a pixel will be considered an outlier. The filter is a modified median filter. If a bright pixel has one or fewer bright neighbors, and the pixel itself has less intensity than the threshold set by this parameter, then it is classified as shot noise and given zero luminosity in the final blur model.

Increasing will: increase the amount of shot noise removed from the blur model. However, if set too high, the actual blur model will be degraded.

Decreasing will: decrease the amount of shot noise removed from the blur model. Setting this parameter to 0 will disable this filtering step.

Deconvolution noise reduction

Adjusts the level of deconvolution noise reduction in the processed image. Adjust this to potentially increase the amount of detail in the processed image, or move it the other way to reduce the visible noise (grain) in the processed image.

Increasing will: make the noise reduction stronger in the processed image. This will potentially reduce the number and severity of some types of visual artifacts, including noise. Another way of thinking about this parameter is that it makes the deblurring (deconvolution) algorithm less sensitive to noise in the input image. However, increasing this value will reduce the amount of detail present in the processed image.

Decreasing will: reduce the noise reduction applied to the processed image. With lower levels of noise reduction, more detail will be visible in the processed image, but the amount of visible noise will be increased.

If you're trying to eek out every last bit of detail from your deblurred image, such as when using Blurity for forensic applications, it's probably a good idea to reduce the level of deconvolution noise reduciton.

If you're planning to use the photos saved by Blurity directly in other applications, you might be bothered by noise in the processed image, so you might want to keep the level of noise reduction higher.

Note: in versions of Blurity prior to 1.4, the level of deconvolution noise reduction was effectively fixed at 40. If you would like to replicate the results from those earlier versions, simply change the deconvolution noise reduction level to that value.

The computed blur model

Short version:

The blur model shows what a single white pixel in the sharp image would look like when blurred like the blur in the blurry image.

If the blur model looks like the blur in the blurry image, the blur removal is as good as it gets. If it doesn't look like the blur in the image, there is room for improvement, so try chaning parameters.

If the blur model is "noisy", the model is poor, so try changing parameters.

The computed blur model shows what Blurity thinks the blur looks like.

It's more than a pretty picture. You can use the blur model to guide your refinement of the deblurring parameters.

In an ideal blur removal case, the computed blur model should look like the blur in the photo. In particular, it should look like the "point spread function" or PSF of the blur. You can think of the PSF as what a single point of light would look like when blurred like the blur in the image.

Often times the PSF is visible in the image where shiny objects are reflecting light. In a sharp image, you'd expect those reflections to be very bright points of light. Instead, when blurred by motion, those single points become spread out into lines. The lines might be straight, curved, or double back on themselves.

Another way to think of the PSF is as a drawing of the motion of the camera while the shutter was open.

Consider this portion of the blurry mug and watch. It shows significant motion blur.

The blur in this image goes from the top left to the bottom right in a wavy manner.

Notice how there is a repeating pattern of wavy lines. That's what the blur looks like.

When we run Blurity on the image, and we get a good computed blur model, we see that the blur model looks just like the blur. In other words, it looks just like the wavy lines.

The computed blur model should look like the blur when it has been created successfully.

By computing an accurate model of the blur, the blur can be removed. The result is that the wavy blur lines (the PSF) turn into points of light.

The wavy blur lines turn into points of light when the blur model is accurate

However, when the computed blur model is just a little bit off, the wavy blur lines do not become points of light in the processed image.

The computed blur model (left) is slightly inaccurate, meaning it doesn't quite look like the blur (center), so the blur removal (right) is poor.

In the above example, the blur model looks a bit like the wavy lines in the photo, but because it's even slightly different, the blur remova is poor.

Adjustment of the blur parameters or the sample box position can improve the model, leading to good blur removal in the processed image.

The computed blur model (left) here is highly accurate. It looks like the blur (center), so the blur removal (right) is good.

If the computed blur model looks nothing like the blur you're trying to remove, or if it's just a bunch of noise, then you probably need to change the blur removal parameters or the sample box position.


Short version:

For normal operation, you don't need to change the preferences.

Several preferences can be set using the Preferences option in the File menu.

Accelerate blur modeling

When enabled, the process for creating blur models is accelerated. This can reduce processing times by 30-60%, but blur removal tends to be worse.

Unless you have a specific reason to enable this mode, we recommend that you leave it disabled. When enabled, we recommend that you use Advanced mode, with slightly more solver filtering and slightly more solver iterations than in the non-accelerated case.

Enable deblug log

When enabled, extra information is written to the event log. Use this option only if directed to by a technical support person.

Blur model save and open

Short version:

You can save and open blur models, allowing you to apply the same blur model to several images quickly.

Blur models can be saved and reopened, allowing you to use a previously calculated blur model on a new image. You can also edit your own blur model and apply it to an image, which can provide additional flexibility if Blurity is unable to compute a blur model on its own.

If you have been trying to deblur a particular image without success, and there is a clear view of the blur in the form of a "glint", you might get better results by extracting the blur, filtering it, and applying it to the image. The procedure is described in a blog post, but be aware: it is an advanced technique that requires additional image processing tools.

Save blur model

After processing, a blur model can be saved as a PNG file.

Open blur model

Once an image has been opened, the option to open a blur model becomes available. Blur models must be PNG files. They should be grayscale (if not, they will be converted when used) and relatively small (less than 99 pixels on a side).

Processing using the selected blur model begins as soon as the blur model is opened.

Load and save settings

Short version:

The processing settings used on one image can be applied to another image.

If you have many similar images of the same scene, such as individual frames from a short video clip, you can apply the deblurring settings from one image to the other images in the series.

This feature is also useful for documenting and saving the settings used to produce a deblurred photo. The deblurring process is deterministic, so reapplying the same deblurring settings to the same input image using the same version of Blurity on the same computer will produce identical results. If the platform or machine vary, the deblurring results might differ by a trivial amount due to variances in how operating systems and CPUs handle floating-point math.

Load settings

A particular combination of settings can either be read from a previously deblurred photo or described in a settings string (see below).

To apply those settings to a new photo, first open the new photo in Blurity using one of the normal methods, such as the "Open image..." button. Select "Load settings..." from the File menu. If you wish to read the processing settings from another image, click "Select image..." and navigate to and select the image. If a settings string can be read from the image, it will be placed in the settings string field and the Accept button will be enabled. Click Accept and note that the deblurring parameter sliders have moved to the positions used in that selected image.

To use a settings string instead of reading a previous image, do as above, but instead of clicking "Select image...", instead paste the settings string into the blank field. If the settings string is valid, the Accept button will be enabled. From there, proceed as with a normal deblurring.

See settings

A settings string corresponding to the currently selected deblurring parameters can be seen in the lower section of the "Load settings..." window. It can be selected and copied for recording or use elsewhere. The settings string is also embedded into all processed images in case you'd like to reproduce the results at some point in the future.

The settings string is stored in the JPEG comment field, which is outside of the EXIF header. It is stored similarly for other image types and can be read using a tool like Image Magick.

5. Tips for good results

Short version:

Don't be affraid to try changing parameters.

Resizing the blurry image to make it smaller can help immensely.

Depending on how the blurry image is blurred, you might get excellent blur removal right away, or you might need to work on it for a while.

What do I (Jeff) do when I'm having trouble getting good blur removal? Glad you asked! Here are the things I try, in roughly the order I try them:

  • Select a different location for the red sample box. Even small changes (like, a couple pixels) can make the difference between no result and a great result.
  • Reduce the number of solver iterations (in Advanced mode). Reducing the number of iterations prevents "over-solving", which can be a problem with noisy images or images that have spatially inconsistent blur.
  • Increase the sample box size. Increasing the box size gives the solver more data to work with.
  • Resize the blurred image so that its dimensions are at least 1/sqrt(2) the size they were, ideally so that the image is no more than 1024x1024 pixels in size (even if it had been substantially larger). Rescaling the image smaller increases the signal-to-noise ratio, which gives the solver better data.
  • Split the blurred image into several parts, deblur them separately, and stitch them back together in Photoshop. This is often necessary when the blur is spatially inconsistent (i.e., the blur is different depending on the location in the image).

6. Troubleshooting

Short version:

Some visual artifacts are normal.

Severe visual artifacts indicate you need to change the blur removal parameters or the sample box location.

Processing errors are often due to trying to operate on a big image with too little RAM in your computer.

If you need further assistance, refer to the support page.

Running into problems? Some commong problems and solutions are below, but if you need more help, please contact us on our support page.

Poor blur removal:

Sometimes, the initial settings will not result in good removal of the blur.


Poor blur removal often results from a bad sample box location, having the number of solver iterations too high, using a sample box size that is too small, or having a blur size setting that is too small.

Adjusting the settings can result in a much better blur removal result:


The above improvement was the result of changing the location of the sample box.

Ringing artifacts:

Moderate ringing looks kind of like an echo of hard edges in the deblurred photo.


Some ringing is normal. It is an artifact of the Fourier transform, which is used by Blurity to remove blurs.

A bit of ringing can sometimes be reduced by adjusting the sample box or the blur parameters.

Severe ringing:

Severe ringing looks something like a zeebra.


Severe ringing indicates that the blur model is very inaccurate. Choose a better sample box location or adjust the blur removal parameters.

Noise in areas of solid color:

Noise can appear in the deblurred image in areas of solid color.


The more noise that is in the input image, the noisier the output image will be. However, you should not necessarily apply noise reduction to the input image, as doing so can remove the latent information that Blurity uses to remove the blur.

Blurity reports that "The sample box location you have chosen is invalid"

Blurity needs a certain amount of information enclosed within the red sample box in order to build a good model of the blur in the photo. If the area enclosed within the sample box is mostly a flat color, then there won't be enough variation present for Blurity to work its magic.

For similar reasons, Blurity needs the area enclosed by the red sample box to be reasonably exposed. If it is very overexposed or underexposed, there won't be enough information present to recover the blur model.

The area in this sample box is completely uniform. It will not work:


There is nothing but black in the sample box, so there is no data to operate on.

This sample box area has some variation, but it is still mostly uniform. In paricular, the areas with detail (the black lines) are all too close to the overexposed, solid flat white area. It too will not work:


Blurity masks out the areas near pure white and pure black, since they represent clipped data and can skew the blur modeling. Thus, any image data in those masked areas is ignored.

This is an example of a good location. It has good variation and good exposure:


Notice how there are no pure-black nor pure-white areas in the sample box. Also notice how the blue area in the middle of the sample box is shaped like a triangle, which will make it a good reference for the blur modeling algorithm and produce good blur removal.

It's too hard to see anything through the watermark

In the free demo version of Blurity, a light watermark is placed over the processed image. Other than the watermark, all results are identical to the paid version. Additionally, the visibility of the watermark is usually an indication of how good the deblurring results are: if the watermark is highly visible, it is likely that the deblurring parameters or the red sample box location are incorrect/sub-optimal for that image. When the deblurring parameters are correct for the image, the watermark tends to be very light, hardly visible at all.

If the watermark is too visible, it's usually an indication that the chosen deblurring parameters are incorrect.

There is no watermark in the registered version of Blurity.

Blurity says that your image is probably too large during processing

Depending on the amount of RAM in your computer, you will probably not be able to deblur images larger than about 6000x4000 pixels. If you need to deblur an image larger than that, you can try reducing the size of the image in a tool like Paint.NET or Photoshop.

Mac OS X reports that Blurity is from an unidentified developer or that the installation disk image is corrupt

This error is caused by Gatekeeper, which is a feature in Mac OS X 10.8 (Mountain Lion). Gatekeeper checks for a digital signature in the application, and if that digital signature is not present, this error is displayed.

You might need to change your Gatekeeper security settngs to allow signed applications from somewhere other than the app store. To do this, launch System Preferences, go to Security & Privacy;, and underneath "Allow applications downloaded from" be sure that "Mac App Store and identified developers" is selected. You might need to click on the lock icon in the lower-left of the window to be able to change your settings.

Versions 1.3.154 of Blurity was the first that was digitally signed for the Mac. If you are seeing this error, please ensure that you have downloaded the newest version of Blurity.

Mac OS X reports that Blurity is damaged and can't be opened

Please ensure that you have downloaded Blurity from the downloads page on this web site. If you have obtained Blurity from somewhere else we can't be responsible for its contents.

Blurity reports a general error during processing

The most common cause of this problem is an over-protective antivirus program. There have been several reports of Norton Antivirus in particular causing errors. Try reconfiguring your antivirus program to be less aggressive around Blurity.

If you are not using an antivirus program, it is likely that you encountered some sort of bug. Please report the bug using the form on our support page. If Blurity displayed a numeric error code in the processing error dialog box, please include that number with your support comment.

7. Uninstallation

Short version:

Blurity uninstalls like pretty much all other software.

If you need to uninstall Blurity from your computer, follow the normal steps for uninstalling any other program.


To uninstall Blurity on Windows, press the Windows key on your keyboard or click the Start menu, then type "Add or remove programs" (without quotes) and press Enter. Click on Blurity in the list of programs that is displayed, then click Uninstall.

Mac OS X

To uninstall Blurity on a Mac, go to your Applications folder and drag Blurity into the trash. After that, choose "Empty Trash" from the Finder menu.